Hi everyone I am having trouble with getting my Firefox macros multi-search to work. It worked in the past, but has now stopped working. Some notes on new approaches: 1. The javascript version of the multi-search scripts at https://fluent-forever.com/multi-search/ would be an awesome update if it weren't for one really important downfall: everytime you search a word, it opens four new tabs, so that multi-word searches involve either burning your browser out with more and more tabs or laboriously closing each tab and starting again. 2. At the same url, 'Firefox Instructions': I bookmark 'Open 6 Tabs', but when I try to run it, nothing happens, and instead I get the following message: "iMacros: Open webpage to run a macro". I bookmark the French Multisearch, but when I click the same thing happens. (I tried bookmarking the Hungarian MultiSearch, and this does run, but it has the same problem described at 1. above. 3. When I try the option of editing the code provided at the following url: https://fluent-forever.com/automate-your-searches/ and then play the macro, it does open a dialogue box. However, when I enter the word, it searches {{!VAR1}} in one tab only and stops. I am pretty certain that I am following the instructions exactly. (I am using the latest version of Firefox and iMacros.) Any help would be greatly appreciated.

* Originally posted by EgonThabo.

Didn't find what you were looking for?

New post
Was this post helpful?
0 out of 0 found this helpful

Comments

15 comments

  • I've had the same issues, in that I don't get a dialog box to enter a word that is separate from the browser.

    My quick fix is to just have the Multisearch dialog be my homepage in Firefox, I don't use Firefox for anything but that anyway so it doesn't get in my way. So when I'm done with one word, I close all the tabs with one click of closing the window entirely, then open Firefox again where I face the blank dialog box and enter my next word.

    It's not elegant but it's a workaround for me and I figured it can't hurt to share.

    * Originally posted by LetsPlayThisBro.
    0
  • Thanks for your reply LetsPlayThisBro. Like you, I would prefer a more elegant solution, but I will definitely keep this workaround in mind.

    * Originally posted by EgonThabo.
    0
  • Hi EgonThabo,
    We are aware that some of the multi searches are not working as they used to and are working on a fix for this. Sometimes switching browsers can help, or workarounds like LetsPlayThisBro suggested.
    Best wishes,
    Heather
    --
    Heather Tucker
    Assistant to Gabriel Wyner

    * Originally posted by Gabriel Wyner.
    0
  • Thanks Heather.

    I have found another workaround for anyone who might be interested: Chrome's Instant Multisearch extension, which together with some chrome shortcuts, is actually quite efficient:

    https://chrome.google.com/webstore/detail/instant-multi-search/aamgapdgopfdmokckpkfciiddpahbbcg

    https://support.google.com/chrome/answer/157179?hl=en

    * Originally posted by EgonThabo.
    0


  • Thanks EgonThabo! I'm looking at that now, looks promising.

    Also I meant to mention this before, but both Firefox and Chrome have the option to "close all tabs to the right".... so if you have a multisearch tab open with the previous word you checked, you can click back to that tab and tell it to do that instead of individually. I do that when I get more than a dozen tabs going, so 3-4 words then boom, close all but the multisearch input tab.

    * Originally posted by LetsPlayThisBro.
    0
  • Been playing with this for about 10 minutes now, can't get it to actually do a search. I set the shortcut to E. I've tried Highlighting a word then using the shortcut key, I put only 2 sites in to multisearch to test it and I must be misunderstanding something in the setup. Will come back when I figure this out, or if you have any tips.

    * Originally posted by LetsPlayThisBro.
    0
  • what is the "close all tabs to the right” shortcut?

    are you entering your letter key and then space bar? this activates the search

    * Originally posted by EgonThabo.
    0
  • ... then enter your word, then 'enter'

    * Originally posted by EgonThabo.
    0
  • If you have multiple tabs open, go to the one on the right, left-click and find close all tabs to the right. Boom. they all close at once. If you do that on the tab that has the multisearch word prompt it will remain and kill any other tabs to it's right.

    As far as entering the letter key and space bar, I am but it keeps feeding me to the top of the page for a google search and it doesn't multi search anything. Maybe I need to change the letter to activate it.

    * Originally posted by LetsPlayThisBro.
    0
  • Nope, and space bar just acts like space bar scrolling down the page a bit.

    * Originally posted by LetsPlayThisBro.
    0
  • are you making sure that the letter is in the correct case - not uppercase?

    * Originally posted by EgonThabo.
    0
  • Hey there, thanks for useful info. I assume you meant 'right click' instead of 'left click'?
    A shortcut I use is Ctrl W to close the current tab :)

    * Originally posted by ganeeeeesh.
    0
  • Yep, good catch, I was awake too long when I wrote that. :) Right click, derp. Gonna double check the case on type.

    * Originally posted by LetsPlayThisBro.
    0
  • Ok, tried again, no go. I just tried to find a youtube tutorial on that extension. Can't find it if it does exist. I still have my workaround but I would like to get this working if I could. But there's only so much time I'm going to devote to try and get it to work.

    * Originally posted by LetsPlayThisBro.
    0
  • I was able to get the Chrome extension to work. I tried to customize it to use the j key but it wasn't successful. I modified the m key to open the tabs I need, and it works well. When I put "m " in the search bar it automatically changes to "Instant Multi Search" and I can paste or type the word I need. My tabs appear just like they're supposed to.

    (Quick instructions for how to modify the extension after you install it:
    1. Click the new gray lightning bolt at the end of the search bar
    2. Click "Options" on the drop-down menu that appears
    3. On the line using the m key, click in the space reserved for web addresses and make your changes.
    4. Click the "Done" button at the bottom of the window.
    5. In the address bar type m and hit the spacebar. If you don't see "Instant Multi Search" appear in your address bar, check your other settings. If it does appear, you're good to go!)

    * Originally posted by LarissaRo.
    0

Please sign in to leave a comment.