I recentley went onto forvo after creating new cards by downloading an mp3 file. However the option to download an mp3 file was not there when I logged on yesterday. I have registered with foevo and was logged in at the time. Can I still download mp3 files off forvo? If not then are there any alternatives?

* Originally posted by billhtc1.

Didn't find what you were looking for?

New post
Was this post helpful?
0 out of 0 found this helpful



  • Hi, I too am having great difficulty trying to download MP3 words from Forvo.
    I had been doing it for some time before they changed the format, and now can´t
    get it to work. I see the downward-pointing arrow but it is not clickable, so
    nothing happens when I click on it. I tried writing to Forvo about a week ago
    but they have not replied. Does anyone know what the problem might be? Thanks
    in advance!

    * Originally posted by jennyassa.
  • They changed the layout of their site yesterday or Monday. When you see a word recording, there is an arrow pointing down along the same line as the word. Click on it, and it will download your recording.

    * Originally posted by Nicolas8241.
  • Thanks

    * Originally posted by billhtc1.
  • need help with downloading words from forvo, like billhtc1 said the download feature is gone, i thought it had to do with the browser i'm using but even i switched browsers still don't see it...i have contacted forvo ITs about this still waiting for reply...the other problem is i can't find any other website like forvo so i'm now stuck with pics with my anki entries...

    * Originally posted by vladimir16.
  • nicolas8241 thanks...i just saw your response now...

    * Originally posted by vladimir16.
  • I am having the same problem.  The click to download MP3 files was working just fine, 2 days ago, and then yesterday it stopped.  I emailed Forvo asking for a solution to this problem.  Did not receive any response yet.  I have used multiple browsers, Chrome, Safari, and enabled Cookies, etc.  Tried again today.  Not working.   Do not know what changed or why.  I too would like a solution to this.  


Please sign in to leave a comment.