I can login from my desktop browser just fine but when I enter the exact same email address & password on my Fluent Forever iPhone app I get this error 'WRONG EMAIL OR PASSWORD', and I'm entering the exact same information. I also clicked on 'Don't Remember your password?' link from the Fluent Forever app but the email never arrived, and I did check my spam box. It's been pretty difficult following all of these steps to get this far, I'm very close and I'd love to finally be able to try out this app. Thanks.

Didn't find what you were looking for?

New post
Was this post helpful?
3 out of 4 found this helpful



  • This is exactly what I’m experiencing.  I can log into the website here just fine, but when I try to login to the app I get the same error as you.  When I try to reset my password it says that it sent me an email, but no email ever arrives.  I’m excited to start using the app!  So far I just can’t get it to cooperate.

  • Hello guys, I am experiencing the same problem at the moment. I have just signed up for the app and installation went smoothly until the log-in page of the app, I am typing the same username-password to the app on the phone but it doesn't accept and let me access to app, even it doesn't show an error, it just returned to the same welcome page which
    you can click on log-in.

    So basically there is a fundamental problem here. Did you solve the same problems of yours until now?
    I sent an email to support department of the fluent forever but I didn't receive anything yet.
    Please somebody tell me how can this problem be solved?


  • Hi there!

    I’m still having the same trouble logging into the app.  I have a request into the support staff, so whenever I get any feedback or solution I’ll post it here.

    I’m looking forward to getting to play with the new app

  • Hello guys,
    Hello Chris,

    I just wanted to inform you that I solved the problem with the app I had.
    Simply my problem was related with the permission of the app to use wireless data.
    (Setting - Fluent - Wireless Data - Allow it)

    Somehow, this permission turned to as deactivated after I installed the app many times.
    After I made it active, it works for me. Please double check that section.
    So it can be related app related setting in IOS or general safari related setting. Please check both to solve the problem.

    Best Regards,




Please sign in to leave a comment.